Delayed Delivery to Inbound Support Emails

Incident Report for Highway

Resolved

Highway's third-party, upstream email support provider has confirmed that its disruption has been resolved. Our teams are able to confirm that support email delivery has returned to normal, and we are working as quickly as possible to address all open requests. We appreciate your patience.
Posted Aug 03, 2026 - 13:57 CDT

Monitoring

Highway's third-party, upstream email support vendor is experiencing a service-impacting issue that is causing delay to the delivery of inbound messages to our support and customer success teams. For immediate support needs, please call 906-HIGHWAY. Current customers, please reach out directly to your customer success manager.
Posted Aug 03, 2026 - 10:26 CDT
This incident affected: External API, Broker Web Application, Carrier, and Onboarding.