Performance Degradation

Incident Report for Highway

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue.
Posted Aug 12, 2026 - 09:54 CDT

Monitoring

Our engineering teams have implemented a fix and are observing site performance return to normal thresholds. We are continuing to monitor, and we appreciate your patience.
Posted Aug 12, 2026 - 09:22 CDT

Update

Our team has identified the cause of the issue and is continuing to make updates to address stability.
Posted Aug 12, 2026 - 09:05 CDT

Investigating

Some users have reported performance degradation within Highway's broker web application. Our teams are investigating the issue and will provide an update by 09:00 CDT.
Posted Aug 12, 2026 - 08:37 CDT
This incident affected: External API, Broker Web Application, Carrier, and Onboarding.