The site has remained fully operational since our fix. Our teams reacted quickly to respond to the issue and we believe the issue is resolved. If you notice any problems please reach out to our customer success team.
Posted Nov 05, 2025 - 08:46 CST
Monitoring
We have implemented some improvements and continue to monitor the site health
Posted Nov 05, 2025 - 08:21 CST
Update
We have brought the site performance back to the expected level. Our team is continuing to monitor and improve the situation.
Posted Nov 05, 2025 - 08:07 CST
Identified
We have identified the cause of the slowness. We are still actively working to resolve this issue.
We’ll provide updates every 30 minutes or as new information becomes available.
Posted Nov 05, 2025 - 08:03 CST
Investigating
Users are experiencing long loading times across the application. Our engineering and infrastructure teams are actively investigating the root cause.
We’ll provide updates every 30 minutes or as new information becomes available.
Posted Nov 05, 2025 - 07:48 CST
This incident affected: External API and Broker Web Application.