FMCSA L&I Data Delayed

Incident Report for Highway

Resolved

This incident has been resolved.
Posted Mar 23, 2026 - 21:05 CDT

Monitoring

L&I Data for Monday, March 23, 2026, has not been provided by the FMCSA. We are aware and monitoring this issue and are working toward resolution.
Posted Mar 23, 2026 - 13:02 CDT
This incident affected: Broker Web Application.