Performance Degradation - Data Visualization

Incident Report for Highway

Resolved

Our engineering teams have observed and confirmed that performance across data visualizations within the broker web application have stabilized. We're considering this incident resolved, and we appreciate your patience.
Posted Jul 08, 2026 - 15:10 CDT

Monitoring

Our engineering teams have identified the issue and implemented a fix. We are observing signs of recovery and will continue to monitor. We appreciate your patience.
Posted Jul 08, 2026 - 12:53 CDT

Investigating

Some customers have reported a performance degradation to data visualizations within the broker web application. Our engineering teams are working with our upstream data visualization provider to identify and remediate the issue.
Posted Jul 08, 2026 - 10:32 CDT
This incident affected: Broker Web Application.