Performance Degradation

Incident Report for Highway

Resolved

Site performance has remained within acceptable limits since our last update, and we are considering this incident as being resolved.
Posted May 27, 2026 - 10:17 CDT

Monitoring

Highway's infrastructure and engineering teams have identified the issue, implemented a fix and are observing signs of recovery. Our teams will continue to monitor site performance through recovery and provide subsequent updates as needed.
Posted May 27, 2026 - 08:25 CDT

Investigating

Some users have reported performance degradation within Highway's broker web application. Our teams are investigating the issue and will provide an update by 08:30 CDT.
Posted May 27, 2026 - 07:54 CDT
This incident affected: External API, Broker Web Application, Carrier, and Onboarding.