Impact to Load Lock & Load Lock+ Alerts

Incident Report for Highway

Resolved

Following Samsara's confirmation that it's service disruption is resolved, as well continuous monitoring thereafter, we can confirm that all features of Load Lock+ and Load Lock are functioning as expecting. We appreciate your patience.
Posted Feb 23, 2026 - 18:00 CST

Update

Samsara has resolved its service disruption. We are seeing all systems fully operational.
Posted Feb 23, 2026 - 15:51 CST

Update

Samsara has stated that the issue has been identified and a fix is in process. We will continue to monitor this issue and ensure our services resume operating as normal once the incident at Samsara is resolved.
Posted Feb 23, 2026 - 15:03 CST

Monitoring

Due to an active service disruption at Samsara, Load Lock Alerts and Load Lock+ arrival and delivery updates related to carriers connected to Samsara may be impacted. Our engineering teams are monitoring this situation and will ensure these services return to normal once the incident at Samsara is resolved.
Posted Feb 23, 2026 - 14:42 CST
This incident affected: External API and Broker Web Application.