Our engineering teams have implemented a fix that has resolved the degraded performance to Highway's External API services, and we are considering the incident resolved. Thank you for your patience!
Posted Jul 02, 2026 - 11:56 CDT
Update
Our engineering teams are continuing to work toward full remediation of degraded performance on our External API services, and we are observing improvement. We will continue to provide updates as the situation progresses, and we appreciate your patience.
Posted Jul 02, 2026 - 10:42 CDT
Identified
Our teams have identified a performance degradation affecting Highway's External API service. We are actively working to remediate the degraded performance. All other services are performing as expected. We appreciate your patience.
Posted Jul 02, 2026 - 09:01 CDT
This incident affected: External API, Broker Web Application, Carrier, and Onboarding.