All systems and TMS integrations are back to operational status. We will continue to monitor site performance closely in preparation for our standard volume spikes on Monday morning. Please contact your Customer Success team if you are experiencing any issues.
Posted May 03, 2025 - 18:33 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 03, 2025 - 12:31 CDT
Update
We have deployed a fix to address the root cause and are still monitoring the issue. We will continue to update as we have more information.
Posted May 03, 2025 - 07:46 CDT
Update
We are continuing to investigate the issue. Next update will be provided in 30 minutes.
Posted May 03, 2025 - 06:42 CDT
Investigating
Scheduled maintenance is still in progress and taking longer than expected. Application functionality is limited. Thank you for your patience. The next update will be provided within the next 30 minutes.
Posted May 03, 2025 - 06:04 CDT
This incident affected: External API and Broker Web Application.